package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\s{4,}`)
var str = `Find all occurrences of 4 or more whitespace characters in a row throughout the string.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}