$re = '/\s{4,}/';
$str = 'Find all occurrences of 4 or more whitespace characters in a row throughout the string.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);