package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)^[p][h][4a][r][_\-]?[m][4a][f][i1][4a]$`)
var str = `pharmafia
ph4rm4f14
phar_mafia
phar-mafia`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}