$re = '/^[p][h][4a][r][_\-]?[m][4a][f][i1][4a]$/mi';
$str = 'pharmafia
ph4rm4f14
phar_mafia
phar-mafia';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);