using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"product/\d+$";
string input = @"product/12someword
product/12";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}