package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`product/\d+$`)
var str = `product/12someword
product/12`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}