use strict;
my $str = 'interface
description xxxxxxx
ip address 127.0.0.1
!
interface Vlan
description xxxxx
ip address 127.0.0.1
ip address 127.0.0.1
no abcd xxxxx eeeee
!';
my $regex = qr/(?:^interface Vlan\r?\n\s*description .*\r?\n|\G(?!\A))\s*(ip address \d{1,3}(?:\.\d{1,3}){3})/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}