$re = '/(?:^interface Vlan\r?\n\s*description .*\r?\n|\G(?!\A))\s*(ip address \d{1,3}(?:\.\d{1,3}){3})/m';
$str = 'interface
description xxxxxxx
ip address 127.0.0.1
!
interface Vlan
description xxxxx
ip address 127.0.0.1
ip address 127.0.0.1
no abcd xxxxx eeeee
!';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);