using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"_(?!\S*_)";
string input = @"FF_SF_FIRE_STRATEGY_G";
RegexOptions options = RegexOptions.Multiline | RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}