$re = '/_(?!\S*_)/ms';
$str = 'FF_SF_FIRE_STRATEGY_G';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);