package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([\.a-z]+)\s\?\s([a-z]+)\s(==|!=)\s?(([a-z]+):([\.a-z]+)\s?)+`)
var str = `test.test ? type == one:prop two:prop`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}