re = /([\.a-z]+)\s\?\s([a-z]+)\s(==|!=)\s?(([a-z]+):([\.a-z]+)\s?)+/m
str = 'test.test ? type == one:prop two:prop'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end