$re = '/\[(?<name>vimeo)[^\]]+\](?:(.*?)\[\/\g<name>\]|(?![^[]*\[\/))/';
$str = '[vimeo align=\'center\' id=\'123\']//player.vimeo.com/video/123[/youtube]
[vimeo align=\'center\' id=\'123\']//player.vimeo.com/video/123[/vimeo]
[vimeo align=\'center\' id=\'123\']dd';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);