re = /\[(?<name>vimeo)[^\]]+\](?:(.*?)\[\/\g<name>\]|(?![^[]*\[\/))/
str = '[vimeo align=\'center\' id=\'123\']//player.vimeo.com/video/123[/youtube]
[vimeo align=\'center\' id=\'123\']//player.vimeo.com/video/123[/vimeo]
[vimeo align=\'center\' id=\'123\']dd'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end