$re = '/(?<=intended).+(?=to match)/';
$str = 'example string with an intended nested string to match.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);