re = /(?<=intended).+(?=to match)/
str = 'example string with an intended nested string to match.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end