import re
regex = re.compile(r"GLOBAL_DATA\(([^)]*)\)(.*?)\};", flags=re.DOTALL)
test_str = ("//\n"
"// GameSettingData.h\n"
"// LowpolyJigsaw\n"
"//\n"
"// Created by Loc Nguyen on 8/4/17.\n"
"//\n"
"//\n\n"
"#ifndef GameSettingData_h\n"
"#define GameSettingData_h\n\n"
"#include \"GameCore/GameData/DataMacro.h\"\n\n"
"enum class GameSpeed\n"
"{\n"
" Slow,\n"
" Normal,\n"
" Fast\n"
"};\n\n"
"struct Address\n"
"{\n"
" DATA(std::string, streetName, \"\");\n"
" DATA(std::string, houseNumber, \"\");\n"
" DATA(std::string, address, \"\");\n"
"};\n\n"
"struct GLOBAL_DATA(GameSettingData)\n"
"{\n"
" GameSettingData()\n"
" {\n"
" address = new Address();\n"
" address->streetName = \"No Trang Long\";\n"
" address->houseNumber = \"13\";\n"
" }\n"
" \n"
" DATA(bool, isSoundEnable, true);\n"
" DATA(bool, isMusicEnable, true);\n"
" DATA(GameSpeed, gameSpeed, GameSpeed::Slow);\n"
" DATA(Address*, address, \"\");\n"
"};\n\n\n"
"struct GLOBAL_DATA(GameSettingData)\n"
"{\n"
" GameSettingData()\n"
" {\n"
" address = new Address();\n"
" address->streetName = \"No Trang Long\";\n"
" address->houseNumber = \"13\";\n"
" }\n"
" \n"
" DATA(bool, isSoundEnable, true);\n"
" DATA(bool, isMusicEnable, true);\n"
" DATA(GameSpeed, gameSpeed, GameSpeed::Slow);\n"
" DATA(Address*, address, \"\");\n"
"};\n"
"#endif /* GameSettingData_h */\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")