using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"AAAAA(?!\""id\"":\""[^""]*\"").*?(\""id\"":\""[^""]*\"")|(?<!^)\G(?!\""id\"":\""[^""]*\"").*?(\""id\"":\""[^""]*\"")(?=.*ZZZZZ)";
string input = @"[]}6778:---esghsrth""id"":""95907bc09-568976456-c6a5a-4f87g""[]}6778:---AAAAA{[]}bla...esghshrth""id"":""95907bc09-568976456-c6a5a-4f87g""[]}6778:---esghsrth""id"":""95907bc09-568976456-c6a5a-4f87g""[]}6778:---esghsrth""id"":""95907bc09-568976456-c6a5a-4f87g""[]}6778:---esghsrth""id"":""95907bc09-568976456-c6a5a-4f87g""[]}6778:---esghsrth""id"":""95907bc09-568976456-c6a5a-4f87g""[]}6778:---esghsrth""id"":""95907bc09-568976456-c6a5a-4f87g""[]}6778:---esghsrth""id"":""95907bc09-568976456-c6a5a-4f87g""[]}6778:---ZZZZZ[]}6778:---esghsrth""id"":""95907bc09-568976456-c6a5a-4f87g""[]}6778:---
Simplified version:
AAAAA(?!id).*?(id)|(?<!^)\G(?!id).*?(id)(?=.*ZZZZZ)
Full version (id => \""id\"":\""[^""]*\"")
AAAAA(?!\""id\"":\""[^""]*\"").*?(\""id\"":\""[^""]*\"")|(?<!^)\G(?!\""id\"":\""[^""]*\"").*?(\""id\"":\""[^""]*\"")(?=.*ZZZZZ)";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}