const regex = /AAAAA(?!\"id\":\"[^"]*\").*?(\"id\":\"[^"]*\")|(?<!^)\G(?!\"id\":\"[^"]*\").*?(\"id\":\"[^"]*\")(?=.*ZZZZZ)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('AAAAA(?!\\"id\\":\\"[^"]*\\").*?(\\"id\\":\\"[^"]*\\")|(?<!^)\\G(?!\\"id\\":\\"[^"]*\\").*?(\\"id\\":\\"[^"]*\\")(?=.*ZZZZZ)', 'g')
const str = `[]}6778:---esghsrth"id":"95907bc09-568976456-c6a5a-4f87g"[]}6778:---AAAAA{[]}bla...esghshrth"id":"95907bc09-568976456-c6a5a-4f87g"[]}6778:---esghsrth"id":"95907bc09-568976456-c6a5a-4f87g"[]}6778:---esghsrth"id":"95907bc09-568976456-c6a5a-4f87g"[]}6778:---esghsrth"id":"95907bc09-568976456-c6a5a-4f87g"[]}6778:---esghsrth"id":"95907bc09-568976456-c6a5a-4f87g"[]}6778:---esghsrth"id":"95907bc09-568976456-c6a5a-4f87g"[]}6778:---esghsrth"id":"95907bc09-568976456-c6a5a-4f87g"[]}6778:---ZZZZZ[]}6778:---esghsrth"id":"95907bc09-568976456-c6a5a-4f87g"[]}6778:---
Simplified version:
AAAAA(?!id).*?(id)|(?<!^)\\G(?!id).*?(id)(?=.*ZZZZZ)
Full version (id => \\"id\\":\\"[^"]*\\")
AAAAA(?!\\"id\\":\\"[^"]*\\").*?(\\"id\\":\\"[^"]*\\")|(?<!^)\\G(?!\\"id\\":\\"[^"]*\\").*?(\\"id\\":\\"[^"]*\\")(?=.*ZZZZZ)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}