# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^([\w]+)\s(.*?)(?=\(|incl\.|[A-Z]$)(?:\(([a-zA-Z]+)-?(.*?)\))?(?:.*(incl.*))?([A-Z])$"
test_str = ("Branded 16 ft Box Truck (Entrent - Avalen Owned) incl. New DSP Insurance PaymentP\n"
"Branded Extended Van (Entrent - Avalen Owned) incl. New DSP Insurance PaymentR\n"
"Branded Custom Van (Entrent - Avalen Owned) incl. New DSP Insurance PaymentR\n"
"Branded Custom Delivery Van (Entrent -Avalen Owned) incl. New DSP\n"
"Branded Extended Van (CeasePlan - Avalen Owned)R\n"
"Branded Extended Van (Entrent - Avalen Owned)R\n"
"Owned Van incl. New DSP Insurance PaymentP\n"
"Rental Van (Unbranded CSP)R\n"
"Owned 16ft Box TruckR\n"
"Branded 24ft Box Truck (Entrent - Leased)P\n"
"Leased Van incl. New Csp Insurance PaymentR")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.