import Foundation
let pattern = #"^([\w]+)\s(.*?)(?=\(|incl\.|[A-Z]$)(?:\(([a-zA-Z]+)-?(.*?)\))?(?:.*(incl.*))?([A-Z])$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Branded 16 ft Box Truck (Entrent - Avalen Owned) incl. New DSP Insurance PaymentP
Branded Extended Van (Entrent - Avalen Owned) incl. New DSP Insurance PaymentR
Branded Custom Van (Entrent - Avalen Owned) incl. New DSP Insurance PaymentR
Branded Custom Delivery Van (Entrent -Avalen Owned) incl. New DSP
Branded Extended Van (CeasePlan - Avalen Owned)R
Branded Extended Van (Entrent - Avalen Owned)R
Owned Van incl. New DSP Insurance PaymentP
Rental Van (Unbranded CSP)R
Owned 16ft Box TruckR
Branded 24ft Box Truck (Entrent - Leased)P
Leased Van incl. New Csp Insurance PaymentR
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)