import re
regex = re.compile(r"\Dshared\Dprograms\D6\Dlessons\D\d{2,6}\Dslide_shows$")
test_str = ("/shared/programs/6/lessons/1126/slide_shows\n"
"/shared/programs/6/lessons/1130/slide_shows\n"
"/shared/programs/6/lessons/965/slide_shows\n"
"/shared/programs/6/lessons/963/slide_shows\n"
"/shared/programs/6/lessons/965/slide_shows\n\n"
"https://subscriptions.teachtci.com/shared/programs/6/lessons/1126/slide_shows\n"
"https://subscriptions.teachtci.com/shared/programs/6/lessons/964/slide_shows\n"
"https://subscriptions.teachtci.com/shared/programs/6/lessons/944/slide_shows\n"
"https://subscriptions.teachtci.com/shared/programs/6/lessons/963/slide_shows\n"
"https://subscriptions.teachtci.com/shared/programs/6/lessons/970/slide_shows\n\n\n\n"
"\\Dshared\\Dprograms\\D6\\Dlessons\\D11\\d{2}\\Dslide_shows$\n"
"\\Dshared\\Dsections\\D\\d{3,5}\\D.{1,10}[=]{0,1}[program_id]*\\D{0,1}109")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")