package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\S+)\s*(.*)\s+(\S+)`)
var str = `one two three four five`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}