$re = '/(\S+)\s*(.*)\s+(\S+)/m';
$str = 'one two three four five';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);