const regex = /^(?=.*\d)[_0-9]{2}-[_0-9]{3}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?=.*\\d)[_0-9]{2}-[_0-9]{3}$', 'gm')
const str = `11-111
_1-111
1_-111
11-__1
11-_1_
11-1__
11-11_
11-1_1
11-_11
11-111
1_-1_1
__-__1
1_-___
__-_1_
_1-___
11-___
__-1__
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}