import re
regex = re.compile(r"^(?=.*\d)[_0-9]{2}-[_0-9]{3}$", flags=re.MULTILINE)
test_str = ("11-111\n"
"_1-111\n"
"1_-111\n"
"11-__1\n"
"11-_1_\n"
"11-1__\n"
"11-11_\n"
"11-1_1\n"
"11-_11\n"
"11-111\n"
"1_-1_1\n"
"__-__1\n"
"1_-___\n"
"__-_1_\n"
"_1-___\n"
"11-___\n"
"__-1__\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")