$re = '/Data Name=\'RuleName\'>technique_id=(?<technique_id>[^,]+),technique_name=(?<technique_name>[^<]+)</m';
$str = '<Data Name=\'RuleName\'>technique_id=T1055.001,technique_name=Dynamic-link Library</Data>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);