use strict;
my $str = 'names=[\'m\',\'c\'], nmodes=2, mus=[[-5.0, -5.0], [5.0, 5.0]], sigmas=[[1.5, 1.5], [2.1, 2.1]], corrcoefs=[[[1.0, -0.7], [-0.7, 1.0]], [[1.0, 0.7], [0.7, 1.0]]], covs=[[[2.25, -1.5749999999999997], [-1.5749999999999997, 2.25]], [[4.41, 3.087], [3.087, 4.41]]], weights=[1.0, 3.0], bounds={\'m\': (-inf, inf), \'c\': (-inf, inf)}';
my $regex = qr/(\w+)=(\[.*?]|{.*?}|\S+)(?=\s*,\s*\w+=|$)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}