import re
regex = re.compile(r"\b([A-Z]{2})[^A-Z0-9]*?([0-9]{1,2})[^A-Z0-9]*?([A-Z]{0,3})[^A-Z0-9]*?([0-9]{4})\b", flags=re.IGNORECASE)
test_str = ("MP13QH3998\n"
"MP-13-QH-3998\n"
"MP 13 QH 3998\n"
"RJ 03QH3918\n"
"RJ 03QH3918\n"
"MP,,,03-QH3998\n"
"MP03QH3998\n\n"
"invalid inputs:\n"
"MP,,01,03-QH3998\n"
"MP0203QH3998\n"
"MP03QJJH3998\n"
"MP03QH399998")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")