re = /\b([A-Z]{2})[^A-Z0-9]*?([0-9]{1,2})[^A-Z0-9]*?([A-Z]{0,3})[^A-Z0-9]*?([0-9]{4})\b/i
str = 'MP13QH3998
MP-13-QH-3998
MP 13 QH 3998
RJ 03QH3918
RJ 03QH3918
MP,,,03-QH3998
MP03QH3998
invalid inputs:
MP,,01,03-QH3998
MP0203QH3998
MP03QJJH3998
MP03QH399998'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end