re = /(="|<)?\b(https?|ftp)(:\/\/[-A-Z0-9+&@#\/%?=~_|[\]()!:,.;]*[-A-Z0-9+&@#\/%=~_|[\])])(?=$|\W)/i
str = 'https://cache-elastic-pandora.ecn.cl/emol/noticia/_search?q=publicada:true+AND+ultimoMinuto:true+AND+seccion:*+AND+temas.id:*&sort=fechaModificacion:desc&size=15&from=45'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end