package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\d{1,2}.\d{1,2}.\d{4}`)
var str = `This is my date: 1.1.2001 fooo bla bla bla
This is my date: 11.11.2001 bla bla foo bla`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}