import Foundation
let pattern = #"\d{1,2}.\d{1,2}.\d{4}"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
This is my date: 1.1.2001 fooo bla bla bla
This is my date: 11.11.2001 bla bla foo bla
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)