$re = '/<(?!(?:[^\'">]|\'[^\']*\'|"[^"]*")+>)[^>]*>/m';
$str = '<p class="quote" style=\' ; dir=\'ltr\'>
<p class="quote" style=\'indent\' ; dir=\'ltr\'>
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);