re = /<(?!(?:[^'">]|'[^']*'|"[^"]*")+>)[^>]*>/m
str = '<p class="quote" style=\' ; dir=\'ltr\'>
<p class="quote" style=\'indent\' ; dir=\'ltr\'>
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end