$re = '/path=[^#&]*/';
$str = 'http://example.com/?foo=bar&path=a/b/c.png/&bar=foo
http://example.com/?foo=bar&path=a/b/c.png&bar=foo';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);