re = /path=[^#&]*/
str = 'http://example.com/?foo=bar&path=a/b/c.png/&bar=foo
http://example.com/?foo=bar&path=a/b/c.png&bar=foo'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end