package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\$(\d+(?:,\d+)*(?:\.\d+)?)`)
var str = `En babyalarm kan koste alt fra $30 til $20.99, afhængigt af de funktioner, du ønsker. De fleste skærme kommer med et grundlæggende sæt funktioner, koster $3,000
$5,123,555`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}