const regex = /\$(\d+(?:,\d+)*(?:\.\d+)?)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\$(\\d+(?:,\\d+)*(?:\\.\\d+)?)', 'gm')
const str = `En babyalarm kan koste alt fra \$30 til \$20.99, afhængigt af de funktioner, du ønsker. De fleste skærme kommer med et grundlæggende sæt funktioner, koster \$3,000
\$5,123,555`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}