const regex = new RegExp('(?:\\$|\\b[A-Z]+)?\\d+', 'gm')
const str = `We four guys, live at 2nd street of Malibeu. I had a cash of \$248 in my pocket. I got a ticket with serial number ABC1234.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}