re = /(?:\$|\b[A-Z]+)?\d+/m
str = 'We four guys, live at 2nd street of Malibeu. I had a cash of $248 in my pocket. I got a ticket with serial number ABC1234.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end