package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\d([A-Za-z]+)\d`)
var str = `testsfa13.4extractthis8488.9090testssffwwww
ajfafs-sss133.6extractthis887878.222testtest522252.9thismore`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}