re = /\d([A-Za-z]+)\d/m
str = 'testsfa13.4extractthis8488.9090testssffwwww
ajfafs-sss133.6extractthis887878.222testtest522252.9thismore'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end