package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)^(?<protocol>https?)?:?(?<slash>\/\/)(?<host>[a-zA-Z0-9]+[\.]+[a-zA-Z0-9-.]+)(?<port>:\d+)?(?<path>[a-zA-Z0-9\/]+.*)?$`)
var str = `https://example.domain
http://example.domain/toto
http://example.domain/index.php?test=1&toto=2
//example.domain
//example.com
https://example.com:34
//example.com:23
example
/var/www/test.css
//var/www/test.css
http://google.com/test.css
https://google.com/text.css
//google.com/test.css
https://cdn.jsdelivr.net/npm/@alma/widgets@4.x.x/dist/widgets.min.css
//cdn.jsdelivr.net/npm/@alma/widgets@4.x.x/dist/widgets.min.css
https:///cdn.jsdelivr.net/npm/@alma/widgets@4.x.x/dist/widgets.min.css
///cdn.jsdelivr.net/npm/@alma/widgets@4.x.x/dist/widgets.min.css
..//widgets.min.css
../widgets.min.css
//google.
http://google.com
test.com`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}