import Foundation
let pattern = #"^(?<protocol>https?)?:?(?<slash>\/\/)(?<host>[a-zA-Z0-9]+[\.]+[a-zA-Z0-9-.]+)(?<port>:\d+)?(?<path>[a-zA-Z0-9\/]+.*)?$"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
https://example.domain
http://example.domain/toto
http://example.domain/index.php?test=1&toto=2
//example.domain
//example.com
https://example.com:34
//example.com:23
example
/var/www/test.css
//var/www/test.css
http://google.com/test.css
https://google.com/text.css
//google.com/test.css
https://cdn.jsdelivr.net/npm/@alma/widgets@4.x.x/dist/widgets.min.css
//cdn.jsdelivr.net/npm/@alma/widgets@4.x.x/dist/widgets.min.css
https:///cdn.jsdelivr.net/npm/@alma/widgets@4.x.x/dist/widgets.min.css
///cdn.jsdelivr.net/npm/@alma/widgets@4.x.x/dist/widgets.min.css
..//widgets.min.css
../widgets.min.css
//google.
http://google.com
test.com
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)