import re
regex = re.compile(r"""
(?|
(\[) (?= \h* x \h* ] ) | (?<= \[ ) \h* x \h* (])
)
|
(?:
(x)
)
""", flags=re.MULTILINE | re.VERBOSE)
test_str = ("Yes: [x]\n"
"Yes: [ x]\n"
"Yes: [x ]\n"
"Yes: [ x ]\n"
"No: [x\n"
"No: x]\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")