re = /(?|
(\[) (?= \h* x \h* ] ) | (?<= \[ ) \h* x \h* (])
)
|
(?:
(x)
)/mx
str = 'Yes: [x]
Yes: [ x]
Yes: [x ]
Yes: [ x ]
No: [x
No: x]
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end