$re = '/[^\w\s]*\breplace\b[^\w\s]*/m';
$str = 'replace
replace(
$replace
$replace()
areplace
replacea';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);