re = /[^\w\s]*\breplace\b[^\w\s]*/m
str = 'replace
replace(
$replace
$replace()
areplace
replacea'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end