package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\d+)_(\d+)`)
var str = ` \1800_411.pdf.log
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}